• Welcome to engineeringclicks.com
  • 3D connexion space explorer rotation help needed.

    Discussion in 'SolidWorks' started by brads, May 29, 2014.

    1. brads

      brads Active Member

      Joined:
      Sep 2012
      Posts:
      38
      Likes Received:
      0
      I have just downloaded the latest driver for my 3D mouse. Now the rotation axis are all wrong and I have tried changing every setting I can find but I can’t reset this back to the way it was.

      This is really difficult to explain but I am sure that when using the old driver I had it set up so that as I looked at a SolidWorks model if I turned the 3D mouse clockwise the model would turn clockwise regardless of axis orientation. Now I have downloaded the new driver when I turn the mouse clockwise the model will always rotate around a specific axis.

      I want to set up the mouse so that the SolidWorks view I am looking at behaves in exactly the same way I am moving the ‘joystick’ on the 3D mouse. So if I move it down the view moves down…. Roll it to the right then the view rolls to the right….. Regardless of what view (front, right, top) I am looking at.

      Does anybody know how to set the mouse up in this way?
       
    2.  
    3. brads

      brads Active Member

      Joined:
      Sep 2012
      Posts:
      38
      Likes Received:
      0
      This is so annoying, does anybody know how to change the rotation settings using the latest driver?

      I think I'm going to have to bin the mouse as its just slowing me down now.
       
    4. mo53ley

      mo53ley New Member

      Joined:
      Jun 2014
      Posts:
      1
      Likes Received:
      0
      Hope I can help

      Hi brads, John from 3Dconnexion here. Sorry to hear you are having issues with the new driver. It sounds quite strange and the best course is usually to contact our tech support team. Before then, I'm wondering a couple of things...

      1. I assume you have toggled "Auto" on and off for the Rotation Center? (Advanced Settings panel via Properties)
      2. Have you seen the "Other Options" menu on the Advanced Settings panel? It's possible this menu is being missed as the text looks greyed out. Look out for the text next to the words "Rotation Center". There may be a setting there that helps...

      Failing that, please contact our tech support team. We would really like to understand what's going on in case it affects other SolidWorks users: http://www.3dconnexion.co.uk/service/technical-support.html

      All the best

      John
       
    5. brads

      brads Active Member

      Joined:
      Sep 2012
      Posts:
      38
      Likes Received:
      0
      Hello John,

      Thank you for your reply; I missed it all those months ago.

      As an updated, I had already tried the steps you highlighted above and it made no difference or made it worse.

      However I have now solved the problem. I downloaded a different version of the driver. It was one recent enough to be supported by SolidWorks 2014 but not so recent that I had issues. From what I can gather from the versions of the program I downloaded the Space Explorer must have changed about a year ago and it now has different buttons to mine which I guess is 4 years old.

      I did contact 3D connexion who after 2 weeks advised I could change what each of the buttons do from a drop down menu. Quite funny.
       

    Share This Page